Report Suspicious / PhishAlarm

Incident Report for Proofpoint Security Awareness

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 17:56 EDT

Investigating

A small subset of customers may experience an error using PhishAlarm for all users: "Please verify that your email address is registered in the Security Awareness Training Platform with your administrator."

Our team is engaged and working to restore service. We will update here shortly.
Most customers are not impacted.
Posted Jul 18, 2025 - 13:08 EDT
This incident affected: U.S. Environment (PhishAlarm - CLEAR - U.S.), Europe Environment (PhishAlarm - CLEAR - Europe), and Asia/Pacific Environment (PhishAlarm - CLEAR - Asia Pacific).