We identified an issue following a recent platform update that impacted campaign scheduling and delivery for a subset of customers. This specifically affected campaigns with simulations scheduled to send after Tuesday, April 28 (AP ), Wednesday April 29 (EU), and Thursday April 30 (US).
- Campaigns in a Pending or Created state with a past start date did not begin as expected and no emails were sent. - Campaigns that were already in progress at the time of the update, and had already successfully sent emails prior to the update, will not send any further emails.
The issue has been resolved, and campaign processing is now functioning as expected. We have also improved our observability to better detect and prevent similar delays or disruptions in the future.
Next steps for impacted customers:
- For campaigns that did not start: clone the campaign, delete the inactive one, and update the schedule before relaunching. - For campaigns partially sent: create a new campaign targeting only users who did not receive emails to preserve scheduling behavior.
We sincerely apologize for the inconvenience and any additional effort required. This occurred as part of ongoing platform modernization efforts aimed at improving overall system performance and reliability. If you need assistance, please contact our support team.
Posted May 06, 2026 - 17:00 EDT
Identified
We recently identified an issue affecting some phishing simulation campaigns following a system update.
Our team has determined the root cause and is actively working on a solution to address the impact. We are taking steps to ensure affected campaigns are handled appropriately and will provide updates as progress is made.
We apologize for any disruption this may have caused and appreciate your patience while we work to resolve this.
Posted May 01, 2026 - 16:00 EDT
This incident affected: U.S. Environment (Simulated Phishing - U.S.), Europe Environment (Simulated Phishing - Europe), Asia/Pacific Environment (Simulated Phishing - Asia Pacific), Canada Environment (Simulated Phishing - Canada), and India Environment (Simulated Phishing - India).